A fix has been implemented and we are monitoring the results.
Posted Mar 24, 2026 - 16:33 EDT
Update
We are completing additional testing before we release the fix for this issue. We will provide another update by 4:30pm EST.
Posted Mar 24, 2026 - 15:39 EDT
Update
We are continuing to work on the fix for this issue and we will provide another update by 3:30pm EST.
Posted Mar 24, 2026 - 15:03 EDT
Update
We are continuing to work on the fix for this issue and we will provide another update by 2:30pm EST.
Posted Mar 24, 2026 - 13:49 EDT
Identified
We’ve identified the cause of the issue. We are actively working on the fix and we will provide another update by 1:30pm EST.
Posted Mar 24, 2026 - 12:29 EDT
Investigating
We're investigating reports of the CSAT survey being presented at unexpected times. Users may see a survey presented in followup conversations that are not tied to a conversation with a human or ai agent.