A fix has been implemented and we are monitoring the results.
Posted May 25, 2026 - 11:46 EDT
Identified
The root of the issue has been identified and we are currently working to resolve the latency observed in the dashboard.
Posted May 25, 2026 - 10:57 EDT
Investigating
We are currently investigating a reported delay in the conversation view for new conversations - currently we are seeing an average delay of 5-10 minutes for new conversations entering the dashboard
Posted May 25, 2026 - 10:28 EDT
This incident affected: Dashboard (Data & Analytics, Dashboard).