A fix has been implemented and we are monitoring the results.
Posted Nov 12, 2025 - 15:00 EST
Update
We are continuing to investigate the issue.
Posted Nov 12, 2025 - 14:01 EST
Investigating
We’re investigating reports of delays in chat loading and message delivery. Some users may see slower-than-normal response times. Our engineers are working on it. Next update in 30 minutes.
Posted Nov 12, 2025 - 12:30 EST
This incident affected: Channels (Email, Social Messaging, Voice, Chat).