The certificate rotation issue has been fully resolved. Error rates have returned to normal levels and services are operating as expected. No further impact is anticipated
Posted May 11, 2026 - 10:49 EDT
Monitoring
A fix has been applied and error rates have returned to normal. Emergency handoffs have dropped to zero. Our team will continue monitoring overnight to confirm full resolution. We will provide a final update once we have confirmed stability.
Posted May 10, 2026 - 18:14 EDT
Update
Our engineering team continues to apply the fix across all services. Customer impact remains stable and low. The rollout is in progress and we will provide another update in 30 minutes or when the issue is resolved.
Posted May 10, 2026 - 17:31 EDT
Update
Our engineering team continues to roll out the fix. Error rates remain stable and we are monitoring for improvement. We will provide another update in 30 minutes.
Posted May 10, 2026 - 16:50 EDT
Identified
We have identified the root cause of the elevated error rates affecting AI Agent responses. Our engineering team is actively rolling out a fix. Customer impact remains low and stable.
Posted May 10, 2026 - 16:16 EDT
Investigating
We are currently investigating elevated error rates affecting AI Agent responses. A small subset of requests are experiencing timeouts, which may result in increased handoffs to live agents. Our team is actively investigating the root cause and will provide updates as more information becomes available.
Posted May 10, 2026 - 15:55 EDT
This incident affected: AI Agent and Agent Handoffs.