Analytics Data Delay
Incident Report for Ada
Resolved
This incident has been resolved.
Posted Oct 31, 2019 - 15:34 EDT
Monitoring
Related to performance issues on our database, Analytics data may be delayed by a few hours. We will update this when data is fresh again.
Posted Oct 31, 2019 - 09:54 EDT
This incident affected: Dashboard (Dashboard (US)).