A fix has been implemented and we're monitoring results. Some conversation data must still be processed and users may take some time to see all their missing conversations appear in the conversations view.
Posted Mar 25, 2026 - 15:28 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Mar 25, 2026 - 15:27 EDT
Investigating
We are currently investigating reports of delays in the Conversations View. Some clients may notice delays in conversations and new messages appearing in their dashboard.
Posted Mar 25, 2026 - 13:46 EDT
This incident affected: Dashboard (Data & Analytics).