Live agent message latency has returned to normal. We are continuing to monitor performance.
Posted Sep 18, 2025 - 11:39 EDT
Identified
We’ve identified the issue is due to a service disruption with one of our live chat partners. They have been notified.
Posted Sep 18, 2025 - 10:56 EDT
Update
We’ve identified the issue is due to a service disruption with one of our live chat partners. They have been notified.
Posted Sep 18, 2025 - 10:54 EDT
Investigating
We’re investigating reports of delays in sending live agent chat messages. Users may see slower-than-normal response times. Our engineers are working on it. Next update in 30 minutes.