Token vault disconnection in non-US clusters
Incident Report for Ada
Resolved
This incident has been resolved.
Posted Jun 06, 2024 - 17:05 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 06, 2024 - 16:53 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 06, 2024 - 16:16 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jun 06, 2024 - 15:40 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 06, 2024 - 15:10 EDT
Investigating
Issue: the token vault used in non-US clusters is disconnected from the list of stored tokens. Tokens stored in v1 of this integration will not be available in bots on these clusters.
Who is affected: bots that are hosted in non-US clusters. These will have a cluster name between the data handle (Eg. bot name) and "ada.support" portion of their address (eg. https://bot-name.custom-cluster.ada.support). Affected bots will see flows/calls that use these tokens fail (eg. request valls using token variables).

Our team is working on restoring the connection to the tokens but if the bot is using the newest version of the token vault it will not be affected.
Posted Jun 06, 2024 - 15:09 EDT
This incident affected: Ada Dashboard.