This incident is resolved. There were issues with one of our upstream providers which has been resolved. Analytics data backfill will take up to a day to process all the data it missed during the day of downtime.
Posted Oct 21, 2025 - 14:58 EDT
Monitoring
A fix has been implemented and we are monitoring results. Data displayed in dashboards and reports may be partial or incomplete until the data backfill completes. We will provide a further update on when data is expected to be completely backfilled.
Posted Oct 21, 2025 - 14:40 EDT
Investigating
Some of our customers may have difficulty loading analytics and performance dashboards. They may not be rendering properly. We do not see any data loss and the issue is affecting the UI only at this time.